Announcement

Collapse
No announcement yet.

Speedometer cable destroyed

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Speedometer cable destroyed

    Hi Deve, My speedometer cable just kinked up and I installed a new one and it did the same thing in half a block. I see there is a small spring at the connection on the transmission and it is tapered. Can't remember which way it should go in......any hints are appreciated! Terry

  • #2
    I'm not sure Terry. I wasn't aware there even was a spring there. I have never seen a spring when replacing them.
    Deve Krehbiel
    devestechnet.com
    forums.devestechnet.com

    Comment


    • #3
      I have never seen a spring on any speedometer cable.
      Sounds like you need to lube your speedometer head.

      Comment


      • #4
        The spring is in the hole on the side of my 4 speed transmission where the cable screws in.

        Comment


        • #5
          Will lube the head. Do you recommend any special type of lube?

          Comment


          • #6
            Are you familiar with the lube point on the speedo head?
            It is a small concave soft plug. Under the plug is a felt wick.
            You would put a few drops of light oil on the wick.

            BTW, any spring on the cable is something someone added.

            Comment


            • #7
              Thanks, I will look for the plug! The spring is not on the cable - it's in the hole on the side of the transmission.

              Comment


              • #8
                Never a spring on any Chevrolet speedo gear from the factory.

                You will need to pull the speedo head out of the housing to access the plug.
                The plug is half covered by the housing.
                It requires a small sharp screw driver to dig into the side of the plug to pry it out.
                Last edited by Pre68Dave; 09-01-2017, 08:02 PM.

                Comment

                Working...
                X